View Menu

The View menu is mainly used to change the way objects look in the Object Browser. It provides a variety of options for viewing tables and sorting databases. You can also create your own entity filters to choose from, and view a user's and server's query history to access more detailed user- and server-related information.

The following is a list of commands that can be accessed from the View menu:

Command Description
Quoted Identifiers Parenthesizes each identifier (databases, tables, and so on).
Entity Schema Displays the object's entity schema in the Object Browser.

The Entity Schema command overrides the Show Schema application option for the current Workbench session. For example, if Show Schema is cleared in the application options (the schema name is hidden from object names), you can select Entity Schema to display the schema name at the beginning of the object names in the Object Browser for the current session. When you exit and restart Workbench, the specified Show Schema setting is reapplied to the object names.

Group by Schema Groups objects by entity schema in the Object Browser.

The Group by Schema command overrides the Group entities by schema application option for the current Workbench session. For example, if Group entities by schema is cleared in the application options (database objects are not grouped by schema in the Object Browser), you can select Group by Schema to display schema groupings for the current session. When exit and restart Workbench, the specified Group entities by schema setting is reapplied.

Sort Columns Alphabetically Displays object columns alphabetically in the Object Browser, as opposed to the physical column order, defined by the schema.
Entity Filter Allows you to manage the existing entity filters, and create new ones. Those objects that do not meet the filtering criteria are not displayed in the Object Browser tree.
User Query History

Displays the current user's Query History. The application keeps a history of your queries issued from the current workstation. The data is stored on the user's PC. This option is useful if you need to know if some specific SQL command or query has been executed by the current user. By default, the main workspace of the window contains a list of all user queries issued from your current workstation. When a history record is selected and highlighted, the query is displayed in full at the bottom of the window. The query list can be filtered using the filters at the top of the window.

If you want to locate a specific text, type it in the Find box, or, if the keyboard focus is on the history grid, just start typing the text to make a search for it.

The number of records in the history is defined in the application settings, and it is available in Tools > Options.

Server Query History

Displays a history of recently executed queries on the server. The data is stored on the server in a special history database (if it was initialized by the DB administrator).

This functionality does not use a Query History database if it was configured for the database host you are connected to. It uses a system default history of the most recent queries (up to 2000 by default, that can be adjusted in the database system configuration).

Toggle Object Browser Allows you to manage the visibility of the Object Browser, providing more space.


Aginity Workbench for Greenplum * Topic last updated August 30, 2018